操盘手之家是国内最好的最全面的股票知识学习网站,提供股票基础知识,股票入门书籍和视频教程,技术指标教程等。
您现在的位置:操盘手之家 > 指标公式 > 通达信牛熊线源码(指标源码)

通达信牛熊线源码(指标源码)   

来源:操盘手之家  阅读: 2020年09月18日 20:57:01
通达信牛熊线源码(通达信) 用法注释:判断股票运行趋势强弱的方法,被称为“牛熊三色”,牛熊三色每翻红一色,就可以增加1/3的仓位,三色全翻红的时候基本可以满仓。这三色分别是:MACD指标,DIFF金叉DEA,即MACD出现红柱的时候即为翻红;SAR指标,股价重新回到SRA指标以上,SAR转向到股价之下运行即为翻红;EXPMA指标,7号操盘线(参数7)金叉2号操盘线(参数21)即为翻红。

参数:M1 2 100 7
M2 2 100 21
N 2 100 4
S 2 100 2
M 2 100 20
源码:
EXP1:EXPMA(CLOSE,M1);
EXP2:EXPMA(CLOSE,M2);
A:IF(CLOSE>SAR(N,S,M),SAR(N,S,M),DRAWNULL),CIRCLEDOT,COLORRED;
B:IF(CLOSE<SAR(N,S,M),SAR(N,S,M),DRAWNULL),CIRCLEDOT,COLORCYAN;
高1:=REF(HHV(H,150),3);
低1:=REF(LLV(L,150),3);
H3:=高1-(高1-低1)*0.5;
中轴:REFDATE(H3,DATE),POINTDOT,COLORLIGRAY,LINETHICK3;
B1:=EMA(C,12);
B2:=EMA(C,26);
B3:=(B1-B2)*2;
WDIF:中轴+B3;
WDEA:EMA(WDIF,9);
MACD:=2*(WDIF-WDEA);
STICKLINE(MACD>0,中轴,中轴+MACD,0,1),COLORYELLOW;
STICKLINE(MACD<0,中轴,中轴+MACD,0,1),COLORLIBLUE;

  以上是本站关于“牛熊线源码(通达信)”的详细内容介绍,更多精彩请收藏本站。

编辑:一痣定江山