操盘手之家是国内最好的最全面的股票知识学习网站,提供股票基础知识,股票入门书籍和视频教程,技术指标教程等。
您现在的位置:操盘手之家 > 指标公式 > 不变形不压缩的MACD主图(大智慧)

不变形不压缩的MACD主图(大智慧)   

来源:操盘手之家  阅读: 2020年08月04日 11:41:51

1、公式基于一品茶缘的“一品四图”黄金分割,
2、为更清晰体现MACD的“完美体形”,该公式不加更多其它渲染
{源码奉上,大家多提不足之处};

{以下设置均线};
MA1:MA(C,5),colorFFFFFF,LAYER0;
MA2:MA(C,10),color00CCFF,LAYER0;
MA3:MA(C,20),colorFF00FF;
MA4:MA(C,30),color00FF00;
{以下设置黄金分割};
W:=BARSLAST(DISPSTATUS=1);
P:=BACKSET(DISPSTATUS=2,W/2+20);
K:=BARSLAST(CROSS(P,0.5));
KJ:=HHVALL(HIGH)-LLVALL(LOW);
平衡:LLVALL(LOW)+KJ/2,COLOR888888,POINTDOT,PRECIS2,LAYER0;
压力:IF(K>=0,HHVALL(HIGH)-KJ*0.191,平衡),COLOR5050FF,POINTDOT,PRECIS2,LAYER0;
支撑:IF(K>=0,LLVALL(LOW)+KJ*0.191,平衡),COLORbbff55,POINTDOT,PRECIS2,LAYER0;
中心值:=支撑*0.9;
{以下设置MACD};
FF:=EMA(CLOSE,12)-EMA(CLOSE,26);
AA:=EMA(FF,9);
MMD:=2*(FF-AA);
QDIFF: 中心值+FF,COLORFFFFFF,linethick1,LAYER0;
QDEA: 中心值+AA,COLORYELLOW,linethick1,LAYER0;
STICKLINE(MMD>=0, 中心值+MMD, 中心值,1,0),COLOR5050FF;
STICKLINE(MMD<0, 中心值, 中心值+MMD,1,0),COLORFFFF00;
两周:=ALL(MMD<0,10);
十八天:=ALL(MMD<0,18);
STICKLINE(MMD<0 AND 两周, 中心值, 中心值+MMD,1,0),COLOR00DDDD;
STICKLINE(MMD<0 AND 十八天, 中心值, 中心值+MMD,1,0),COLORFF00FF;


  上述内容是关于“不变形不压缩的MACD主图(大智慧)”的详细说明!关注本站资讯精彩继续。

编辑:独步也逍遥

上一篇:操盘王指标源码(大智慧)

下一篇:没有了