操盘手之家是国内最好的最全面的股票知识学习网站,提供股票基础知识,股票入门书籍和视频教程,技术指标教程等。
您现在的位置:操盘手之家 > 指标公式 > 超好用的135均线战法改进版(大智慧)

超好用的135均线战法改进版(大智慧)   

来源:操盘手之家  阅读: 2020年08月04日 11:41:04

n:=17;
LH:=79;
EMA1:EMA(C,1);
ema13:ema(c,13),COLORFF8080;
ema34:ema(c,34),colorFFFF00;
ema55:ema(c,55),colorff00ff;
ema120:ema(c,120),COLORGREEN;
MA30:MA(C,30),COLORYELLOW,POINTDOT,LINETHICK2;
生命线:eMA(CLOSE,453),colorff00ff,POINTDOT,LINETHICK2;
LOCK:=1;
M8:=EMA(CLOSE,8);
M13:=EMA(M8,13);
VAR1:=EMA(M13,62);
VAR2:=(CLOSE+HIGH+LOW)/3;
VAR3:=EMA(VAR2,10)*LOCK;
VAR4:=REF(VAR3,1)*LOCK;
STICKLINE(OPEN>=CLOSE,CLOSE,OPEN,9*0.5,0),COLORFF5B00;
STICKLINE(OPEN>=CLOSE,CLOSE,OPEN,8*0.5,0),COLORFF6C00;
STICKLINE(OPEN>=CLOSE,CLOSE,OPEN,7*0.5,0),COLORFF7B00;
STICKLINE(OPEN>=CLOSE,CLOSE,OPEN,6*0.5,0),COLORFF9C00;
STICKLINE(OPEN>=CLOSE,CLOSE,OPEN,5*0.5,0),COLORFFBE00;
STICKLINE(OPEN>=CLOSE,CLOSE,OPEN,3.5*0.5,0),COLORFFCC00;
STICKLINE(OPEN>=CLOSE,CLOSE,OPEN,1.5*0.5,0),COLORFFFF00;
STICKLINE(CLOSE>=OPEN,CLOSE,OPEN,9*0.5,0),COLOR070084;
STICKLINE(CLOSE>=OPEN,CLOSE,OPEN,8*0.5,0),COLOR0000A3;
STICKLINE(CLOSE>=OPEN,CLOSE,OPEN,7*0.5,0),COLOR0000B7;
STICKLINE(CLOSE>=OPEN,CLOSE,OPEN,6*0.5,0),COLOR0000CD;
STICKLINE(CLOSE>=OPEN,CLOSE,OPEN,5*0.5,0),COLOR0000E9;
STICKLINE(CLOSE>=OPEN,CLOSE,OPEN,3*0.5,0),COLOR0754E9;
STICKLINE(CLOSE>=OPEN,CLOSE,OPEN,1.5*0.5,0),COLOR076EF3;
STICKLINE(CLOSE>=OPEN,CLOSE,OPEN,1*0.5,0),COLOR077BF3;
STICKLINE(CLOSE>OPEN,OPEN,LOW,1*0.5,0),COLOR0726CA;
STICKLINE(CLOSE>OPEN,CLOSE,HIGH,1*0.5,0),COLOR0726CA;
STICKLINE(OPEN>CLOSE,CLOSE,LOW,1*0.5,0),COLORDE9100;
STICKLINE(OPEN>CLOSE,OPEN,HIGH,1*0.5,0),COLORDE9100;
AAA:=MA(C,10);
BBB:=ATAN((AAA/REF(AAA,1)-1)*100)*180/3.1416;
CCC:=FILTER(CROSS(BBB,30),5);
DRAWTEXT(CCC AND C>AAA,AAA*0.95,'十日30∠'),COLORFF00FF;
ar1:=ema55>ema34 and ema34>ema13;
ar2:=BARSLAST((c-ema13)/ema13*100<-6);
ar3:=ema13>=ref(ema13,2);
ar4:=count(cross(c,ema13),ar2)=1;
ar5:=ar1 and ar2 and ar3 and ar4;
ar6:=ar5 and filter(ar5,10);
drawtext(ar6,l-0.09,'红杏出墙'),COLOR00ccff;
stickline(ar6,h,l,0.5,1),COLOR00ccff;
stickline(ar6,o,c,6,1),linethick2,COLOR00ccff;
br1:=count(BETWEEN((c-ref(c,1))/ref(c,1)*100,0,5) ,5)=5;
br2:=abs((ema13-ema34)+(ema34-ema55))/c<0.2;
br3:=c>ema55 and (ref(c,1)<ref(ema55,1) or ref(c,2)<ref(ema55,2) or ref(c,3)<ref(ema55,3) or ref(c,4)<ref(ema55,4) or ref(c,5)<ref(ema55,5));
br4:=br1 and br2 and br3;
drawtext(br4 and filter(br4,10),l-0.09,'蚂蚁上树'),color00C5FF;
stickline(br4 and filter(br4,10),h,l,0.5,1),color00C5FF;
stickline(br4 and filter(br4,10),o,c,6,1),linethick2,color00C5FF;
cr1:=(c-ref(c,1))/ref(c,1)*100>0.5;
cr2:=v>ma(v,5)*0.6;
cr3:=count(cross(ema13,ema55),3)=1;
cr4:=abs(ema34-ema55)/ema55<0.03;
cr5:=ema55<=ema120 and ema55>=ref(ema55,1);
cr6:=FILTER(cr1 and cr2 and cr3 and cr4 and cr5,2);
stickline(cr6,h,l,0.5,1),colorf00ff0;
stickline(cr6,o,c,6,1),linethick2,colorf00ff0;
drawtext(cr6,l-0.09,'红衣侠女'),colorf00ff0;
dr1:=ema13>ema34 and ema34<ema55;
dr2:=BARSLAST(cross(c,ema55) );
dr3:=h=hhv(h,dr2);
dr4:=BARSLAST(dr3);
dr5:=count(o>c and c<ref(c,1) and c>ema55 and BETWEEN((c-ema55)/ema55,0,0.02),dr4)=1;
dr6:=c>ref(c,1) ;
dr7:= dr1 and dr5 and dr6 ;
dr8:=dr7 and FILTER(dr7 ,10);
drawtext(dr8,l-0.09,'黑客点击'),colord6ba63;
stickline(dr8,h,l,0.5,1),colord6ba63;
stickline(dr8,o,c,6,1),linethick2,colord6ba63;
er:=barslast(ref(cross(ema55,ema34),1)) and cross(ema34,ema55);
DRAWTEXT(er,l-0.09,'均线互换'),color0099ff;
stickline(er,h,l,0.5,1),color0099ff;
stickline(er,o,c,6,1),linethick2,color0099ff;
fr:=barslast(ref(cross(ema34,ema13),1)) and cross(ema13,ema34);
DRAWTEXT(fr,l-0.09,'梅开二度'),colorwhite;
stickline(fr,h,l,0.5,1),colorwhite;
stickline(fr,o,c,6,1),linethick1,colorwhite;
gr1:=BARSLAST(BETWEEN("bias.bias2"(6,13,24),0,5) );
gr2:=ema13>ema34 and ema34>ema55 and ema13>ref(ema13,1);
gr3:=count("bias.bias2"(6,13,24)>10 and h=hhv(h,gr1),gr1);
gr4:=h=hhv(h,gr1);
gr5:="macd.macd"(12,26,9)<ref("macd.macd"(12,26,9),1);
gr6:=gr2 and gr3 and gr4;
gr7:=gr2 and gr3 and gr4 and gr5;
drawtext(gr6 and gr7,h+0.13,'见好就收!'),color00ff00;
DRAWTEXT(gr6 and gr7,h+0.1,'▼'),color00ff00;
hr2:=ema13>=ref(ema13,3) and ema34>=ref(ema34,1) and ema55>=ref(ema55,1) and cross(c,ema13) and cross(c,ema34) and cross(c,ema55);
DRAWTEXT(hr2 and filter(hr2,10),h+0.1,'▲'),colorFFC8FF;
DRAWTEXT(hr2 and filter(hr2,10),h+0.5,'揭竿而起'),color9900cc;
DRAWTEXT(hr2 and filter(hr2,10),l-0.09,'三线推进'),COLORYELLOW;
stickline(hr2 and filter(hr2,10),h,l,0.5,1),COLORYELLOW;
stickline(hr2 and filter(hr2,10),o,c,6,1),linethick2,COLORYELLOW;
SK:= EMA(Var1,13)-EMA(Var1,73);
SD:= EMA(SK,2);
drawtext((cross(sk,sd) and sk<-0.04 and (c-ref(c,1))/ref(c,1)>=0.03) or (cross(sk,sd) and sk<=-0.14 )
or (cross(sk,sd) and sk<=0.05 and (v/ma(v,5)>2 or c/ref(c,1)>0.035)) ,l*0.99,'短'),COLOR0000cc;
stickline((cross(sk,sd) and sk<-0.04 and (c-ref(c,1))/ref(c,1)>=0.03) or (cross(sk,sd) and sk<=-0.14 )
or (cross(sk,sd) and sk<=0.05 and (v/ma(v,5)>2 or c/ref(c,1)>0.035)),h,l,0.5,0),COLOR0000cc;
stickline((cross(sk,sd) and sk<-0.04 and (c-ref(c,1))/ref(c,1)>=0.03) or (cross(sk,sd) and sk<=-0.14 )
or (cross(sk,sd) and sk<=0.05 and (v/ma(v,5)>2 or c/ref(c,1)>0.035)),o,c,10,1),linethick1,COLOR0000cc;
MA1:=MA(((HIGH + LOW) / 2),5);MA2:=MA(((HIGH + LOW) / 2),35);x:=((MA1 - MA2) * 100);
均势一:=(((((((((CLOSE + REF(CLOSE,1)) + REF(CLOSE,2)) + REF(CLOSE,3)) + REF(CLOSE,4)) + REF(CLOSE,5)) + REF(CLOSE,6)) + REF(CLOSE,7)) + REF(CLOSE,8)) / 9);
均势二:=((((CLOSE + REF(CLOSE,1)) + REF(CLOSE,2)) + REF(CLOSE,3)) / 4);
趋势一:=((((均势一 - REF(均势一,1)) / REF(均势一,1)) * 1000) + 50);
趋势二:=((((均势二 - REF(均势二,1)) / REF(均势二,1)) * 1000) + 50);
波段高位:=(CROSS(趋势一,趋势二) AND (COUNT((CLOSE > REF(HIGH,1)),12) > 5));
LC:=REF(CLOSE,1);
方向值:=((SMA(MAX((CLOSE - LC),0),6,1) / SMA(ABS((CLOSE - LC)),6,1)) * 100);
短抄一:=((CROSS(趋势二,(趋势一 + 2)) AND (x < 0)) AND ((方向值 < 10) OR (REF(方向值,1) < 10)));
短抄二:=((((CROSS(趋势二,MA1) AND (MA1 < 20)) AND (方向值 > 趋势二)) AND (x < 0)) AND
(((趋势二 < 20) OR (REF(趋势二,1) < 15)) OR (REF(趋势二,2) < 15)));
DRAWTEXT((短抄一 OR 短抄二),(LOW * 0.99),'短底'),Color0000FF;
DRAWTEXT(波段高位,(HIGH * 1.03),'卖出'),colorWhite;
DRAWICON(波段高位,(HIGH * 1.06),2),colorFF0000;DRAWICON((短抄一 OR 短抄二),(LOW * 0.97),1);
V5:=EMA(CLOSE,1);主线:=EMA(V5,5) ;
本:=EMA(HHV(主线,5),1);
急进:=EMA(HHV(本,17),1);
稳健:=EMA(HHV(急进,17),2);
投资:EMA(HHV(稳健,17),3),linethick2, colorgray;
Y:=(MA(C,13)-MA(C,55))/MA(C,13)*100;
YY1:=C>MA(C,13) AND OPEN<MA(C,13);{一阳三线}
YY3:=C>MA(C,34) AND OPEN<MA(C,34);
YY5:=C>MA(C,55) AND OPEN<MA(C,55);
X2:DRAWTEXT(YY1 AND YY5 AND YY3,LOW-0.1,'一阳三线'),COLORRED;
SJ1:=ABS(MA(CLOSE,13)-MA(CLOSE,34))<C*0.01;{13线34线55线接近}
SJ2:=ABS(MA(CLOSE,34)-MA(CLOSE,55))<C*0.01;
SJ3:=CROSS(MA(CLOSE,13),MA(CLOSE,55));{13线上穿55线}
X3:DRAWTEXT(SJ1 AND SJ2 AND SJ3,HIGH+0.1,'三军集结'),COLORRED;
RY1:=C/OPEN>1.04;{阳线4%}
RY2:=REF(OPEN,1)/REF(CLOSE,1)>1.04;{阴线4%}
RY3:=ABS(OPEN-REF(C,1))<C*0.02 AND ABS(C-REF(OPEN,1))<C*0.02;{两线相等}
X4:DRAWTEXT(RY1 AND RY2 AND RY3 ,LOW,'日月合璧'),COLORYELLOW;
JW1:=C<OPEN AND REF(C,1)<REF(OPEN,1);
JW2:=OPEN<REF(C,1) AND C>REF(L,1);
JW3:=O<MA(C,13) AND O<MA(C,34) AND O<MA(C,55);
JW:=JW1 AND JW2 AND JW3;
X8:DRAWTEXT(JW,LOW-0.2,'金屋藏娇'),COLORYELLOW;
TS1:=CROSS(MA(C,13),MA(C,34));{13线上穿34线}
TS2:=MA(C,13)<MA(C,55);
TS:=TS1 AND TS2;
X9:DRAWTEXT(TS,LOW-0.2,'投石问路'),COLORF00FF0;
YZ1:=C/O>1.02 AND H/C>1.02 AND O/L<1.02;{收阳有上影}
YZ2:=REF(C,1)>REF(O,1) AND O>MA(C,11);{昨收阳 今大于均线}
YZ:=YZ1 AND YZ2 AND Y>10;
X11:DRAWTEXT(YZ,HIGH+0.2,'一枝独秀'),COLORF00FF0;
DS1:=OPEN/C>1.04 AND O/REF(C,1)>1.03;{高开收阴}
DS2:=V*100/FINANCE2(7)>0.08 AND Y>8;{换手高涨幅大}
DS:=DS1 AND DS2;
X12:DRAWTEXT(DS,HIGH+0.2,'独上高楼'),COLORGREEN;
YJ1:=H/O>1.04;
YJ2:=ABS(C-O)<C*0.03;
YJ3:=C/MA(C,13)>1.1;
YJ:=YJ1 AND YJ2 AND DS2 AND YJ3 AND YZ2;
X13:DRAWTEXT(YJ,HIGH+0.3,'一剑封喉'),COLORRED;
T:=(MA(C,13)-MA(C,55))/MA(C,13)*100;
TT1:=C<MA(C,13) AND OPEN>MA(C,13);{断头铡刀}
TT3:=C<MA(C,34) AND OPEN>MA(C,34);
TT5:=C<MA(C,55) AND OPEN>MA(C,55);
x28:DRAWTEXT(TT1 AND TT5 AND TT3,LOW-0.6,'断头铡刀'),COLORRED;
x39:DRAWTEXT(CROSS(eMA34,eMA13),eMA34*1.01,'S分道扬镳'), COLOR00FF00;
x30:DRAWTEXT(CROSS(eMA55,eMA13),eMA55*1.01,'S一箭穿心'), COLOR00FF00;
X31:DRAWTEXT(CROSS(eMA55,eMA34),eMA55*1.01,'S各自为政'), COLOR00FF00;

VAR10:=MA(CLOSE,80)-MA(CLOSE,10)/3;
VAR11:=REF(CLOSE,1);
VAR12:=(SMA(MAX(CLOSE-VAR11,0),N,1))/(SMA(ABS(CLOSE-VAR11),N,1))*100;
X14:DRAWTEXT(IF(CLOSE<VAR10 AND VOL/240>MA(VOL,5)/240 AND CLOSE>REF
(CLOSE,1)*1.08 AND CLOSE<MA(CLOSE,13)*1.3,1,0),LOW-0.7,'进场'),COLORRED;
X16:DRAWTEXT(CROSS(LH,VAR12),HIGH*1.04,'获利减仓');
X17:DRAWTEXT(CROSS(VAR3,VAR4),L-0.3,'买'),COLORRed;
X18:DRAWTEXT(CROSS(eMA13,eMA34),H+0.5,'投石,增持'),COLORYELLOW;
X19:DRAWTEXT(CROSS(eMA13,eMA55),H+0.3,'红客,加仓'),COLORYELLOW;
X20:DRAWTEXT(CROSS(eMA34,eMA55),L-0.5,'互换,重仓'),COLORYELLOW;
X21:DRAWTEXT(REF(CLOSE,1)<REF(OPEN,1) AND CLOSE>REF(OPEN,1),
L*0.97,'克阴'),COLORFF00FF;
X22:DRAWTEXT(REF(CLOSE,1)>REF(OPEN,1) AND CLOSE<REF(OPEN,1),
H*1.05,'克阳'),COLOR00FF00;
X23:DRAWICON(CROSS(eMA13,eMA34),eMA34,1);
X24:DRAWICON(CROSS(eMA13,eMA55),eMA55,1);
X25:DRAWICON(CROSS(eMA34,eMA55),eMA55,1);
STICKLINE(HR2 AND FILTER(HR2,10),H,L,0,1),COLORFFC8FF;
FF:=EMA(CLOSE,3);MA15:=EMA(CLOSE,21);
DRAWTEXT(CROSS(FF,MA15),(LOW * 0.99),'←底背'),COLORA6E500;
RSI:=((SMA(MAX((CLOSE - LC),0),3,1) / SMA(ABS((CLOSE - LC)),3,1)) * 100);
DRAWTEXT(CROSS(88,RSI),(HIGH * 1.04),'←顶背'),COLOR1880FF;
X35:DRAWICON(CROSS(eMA13,eMA34),eMA34,1);
X36:DRAWICON(CROSS(eMA13,eMA55),eMA55,1);
X37:DRAWICON(CROSS(eMA34,eMA55),eMA55,1);
X38:DRAWICON(CROSS(eMA34,eMA13),eMA34,2);
X139:DRAWICON(CROSS(eMA55,eMA13),eMA55,2);
X40:DRAWICON(CROSS(eMA55,eMA34),eMA55,2);

  上述内容是关于“超好用的135均线战法改进版(大智慧)”的详细说明!关注本站资讯精彩继续。

编辑:独步也逍遥

上一篇:大智慧6均线资金主图指标公式

下一篇:没有了