操盘手之家是国内最好的最全面的股票知识学习网站,提供股票基础知识,股票入门书籍和视频教程,技术指标教程等。
操盘手之家 > 指标公式 > 通达信公式 > 改进“风险评测”源码有图通达信指标源码

改进“风险评测”源码有图通达信指标源码   

来源:操盘手之家  阅读: 2021年01月11日 22:25:39

{风险测评}RSVA1:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;RSVA2:=100*(HHV(HIGH,9)-CLOSE)/(HHV(HIGH,9)-LLV(LOW,9));VAR21:=SMA(RSVA2,9,1)+100;VAR11:=SMA(RSVA1,3,1);VAR51:=SMA(VAR11,3,1)+100;顶底线:=VAR51-VAR21+50;VAR2:=LLV(LOW,33);VAR3:=HHV(HIGH,21);VAR4:=EMA((CLOSE-VAR2)/(VAR3-VAR2)*100,10)*-1+100;趋势:=100-EMA(0.191*REF(VAR4,1)+0.809*VAR4,1);STICKLINE(C,100,90,4,0),COLORFFCC33;STICKLINE(C,90,80,4,0),COLORFF9933;STICKLINE(顶底线>REF(顶底线,1),20,80,4,0),COLOR9999FF;STICKLINE(顶底线<REF(顶底线,1),20,80,4,0),COLOR009966;STICKLINE((趋势>REF(趋势,1) AND 顶底线<REF(顶底线,1)),20,80,4,0),COLOR9999FF;STICKLINE((趋势<REF(趋势,1) AND 顶底线>REF(顶底线,1)),20,80,4,0),COLOR009966;STICKLINE(C,20,10,4,0),COLORFF6633;STICKLINE(C,10,0,4,0),COLORFF3333;底线:10,COLORWHITE;顶线:90,COLORWHITE;趋势线:100-EMA(0.191*REF(VAR4,1)+0.809*VAR4,1),LINETHICK2,COLORBLUE;当前安全度:100-EMA(0.191*REF(VAR4,1)+0.809*VAR4,1),CIRCLEDOT,LINETHICK2,COLORRED;DRAWTEXT(CURRBARSCOUNT=6,5,'高安全区'),COLORWHITE;DRAWTEXT(CURRBARSCOUNT=6,15,'安全区'),COLORWHITE;DRAWTEXT(CURRBARSCOUNT=6,45,'绿区持币'),COLORFFC000;DRAWTEXT(CURRBARSCOUNT=6,50,'(投资区)'),COLORWHITE;DRAWTEXT(CURRBARSCOUNT=6,55,'粉区持股'),COLORFFC000;DRAWTEXT(CURRBARSCOUNT=6,85,'风险区'),COLORWHITE;DRAWTEXT(CURRBARSCOUNT=6,95,'高风险区'),COLORWHITE;{强拉升}Y1:=LLV(L,17);Y2:=SMA(ABS(L-REF(L,1)),17,1);Y3:=SMA(MAX(L-REF(L,1),0),17,2);Q:=-(EMA(IF(L<=Y1,Y2/Y3,-3),1));STICKLINE(CROSS(Q,0),15,0,4,0), , COLORYELLOW;强拉升: IF(CROSS(Q,0),1,0),COLORYELLOW;Q1:= (CLOSE-MA(CLOSE,40))/MA(CLOSE,40)*100, , COLOR00FF00,LINETHICK2;STICKLINE(CROSS(Q1,-24),20,0,4,0), , COLORMAGENTA;加强拉升: IF(CROSS(Q1,-24),1,0),COLORMAGENTA;VAR22:=EXPMA(EXPMA(EXPMA((2*CLOSE+HIGH+LOW)/4,4),4),4);天:=( MA((VAR22-REF(VAR22,1))/REF(VAR22,1)*100,2));地:=( MA((VAR22-REF(VAR22,1))/REF(VAR22,1)*100,1));STICKLINE(地>天 AND 地<0,10,0,1,0),COLORRED;开始拉升:STICKLINE(地>天 AND 地<0,10,0,1,0)=1,COLORRED;{<<波段绝品>>}VAR1B:=(HHV(HIGH,9)-CLOSE)/(HHV(HIGH,9)-LLV(LOW,9))*100-70;VAR2B:=SMA(VAR1B,9,1)+100;VAR3B:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;VAR4B:=SMA(VAR3B,3,1);VAR5B:=SMA(VAR4B,3,1)+100;VAR6B:=VAR5B-VAR2B;趋势1: IF(VAR6B>45,VAR6B-45,0),COLOR00FFFF,LINETHICK2;VAR2Q:=REF(LOW,1);VAR3Q:=SMA(ABS(LOW-VAR2Q),3,1)/SMA(MAX(LOW-VAR2Q,0),3,1)*100;VAR4Q:=EMA(IF(CLOSE*1.3,VAR3Q*10,VAR3Q/10),3);VAR5Q:=LLV(LOW,30);VAR6Q:=HHV(VAR4Q,30);VAR7Q:=IF(MA(CLOSE,58),1,0);VAR8Q:=EMA(IF(LOW<=VAR5Q,(VAR4Q+VAR6Q*2)/2,0),3)/999*VAR7Q;火焰山:=IF(VAR8Q>100,100,VAR8Q);STICKLINE(火焰山>0 AND 火焰山>REF(火焰山,1),0 ,火焰山*1.2,3.5,0 ),COLOR4444FF;STICKLINE(火焰山>0 AND 火焰山>REF(火焰山,1),0 ,火焰山*1.2,2.5,0 ),COLOR5555FF;STICKLINE(火焰山>0 AND 火焰山>REF(火焰山,1),0 ,火焰山*1.2,1.5,0 ),COLOR7777FF;STICKLINE(火焰山>0 AND 火焰山>REF(火焰山,1),0 ,火焰山*1.2,0.5,0 ),COLOR9999FF;STICKLINE(REF(趋势1,1)< 趋势1, 趋势1,REF(趋势1,1),3.5,0),COLOR000033;STICKLINE(REF(趋势1,1)< 趋势1, 趋势1,REF(趋势1,1),2.8,0),COLOR000055;STICKLINE(REF(趋势1,1)< 趋势1, 趋势1,REF(趋势1,1),2.0,0),COLOR000077;STICKLINE(REF(趋势1,1)< 趋势1, 趋势1,REF(趋势1,1),1.2,0),COLOR000099;STICKLINE(REF(趋势1,1)< 趋势1, 趋势1,REF(趋势1,1),0.4,0),COLOR0000DD;STICKLINE(REF(趋势1,1)> 趋势1, 趋势1,REF(趋势1,1),3.5,0),COLOR003300;STICKLINE(REF(趋势1,1)> 趋势1, 趋势1,REF(趋势1,1),2.8,0),COLOR005500;STICKLINE(REF(趋势1,1)> 趋势1, 趋势1,REF(趋势1,1),2.0,0),COLOR007700;STICKLINE(REF(趋势1,1)> 趋势1, 趋势1,REF(趋势1,1),1.2,0),COLOR009900;STICKLINE(REF(趋势1,1)> 趋势1, 趋势1,REF(趋势1,1),0.4,0),COLOR00DD00;逃顶:=CROSS(82,RSI);STICKLINE( 逃顶,逃顶,10,3.5,0),COLORFF5500;STICKLINE( 逃顶,逃顶,15,2.5,0),COLORFF8800;STICKLINE( 逃顶,逃顶,20,1.5,0),COLORFFAA00;STICKLINE( 逃顶,逃顶,25,0.5,0),COLORFFCC00;STICKLINE( 逃顶,逃顶,30,0.1,0),COLORFFFF00;D1:=(C+L+H)/3;D2:=EMA(D1,6);D3:=EMA(D2,5);BBUY:=CROSS(D2,D3);强弱线:50,COLORGREEN,POINTDOT;DRAWICON(BBUY,20,1);VARR1:=SMA(MAX(CLOSE-REF(C,1),0),6,1)/SMA(ABS(CLOSE-REF(C,1)),6,1)*100;DRAWICON(CROSS(82,VARR1),10,15);DRAWTEXT(CROSS(82,VARR1),35,'逃'),COLORYELLOW;

通达信指标公式

  以上是本站关于“改进“风险评测”源码有图(通达信)”的详细内容介绍,更多精彩请收藏本站。

编辑:赵立赢