操盘手之家是国内最好的最全面的股票知识学习网站,提供股票基础知识,股票入门书籍和视频教程,技术指标教程等。
操盘手之家 > 指标公式 > 通达信公式 > 高点压力出现通达信指标源码

高点压力出现通达信指标源码   

来源:操盘手之家  阅读: 2021年01月11日 22:25:11

布林:=HHV(HHV(L,14),60);阻力区:=EMA(EMA(布林,16)-2*STD(布林,16),3);阻力区1:=EMA(EMA(布林,14)+2*STD(布林,14),18);DRAWBAND(阻力区,RGB(241,241,247),阻力区1,RGB(241,241,247));{=================================================}STICKLINE(C>=O,C,O,3,0),COLOR0000AA;STICKLINE(C>=O,C,O,2.5,0),COLOR0000BB ;STICKLINE(C>=O,C,O,1.5,0),COLOR0000CC ;STICKLINE(C>=O,C,O,1,0),COLOR0000EE;STICKLINE(C>=O,H,L,0,0),COLOR0000FF;STICKLINE(C<=O,C,O,3,0),COLOR7B7B00;STICKLINE(C<=O,C,O,2.5,0),COLOR909000;STICKLINE(C<=O,C,O,1.5,0),COLORA8A800;STICKLINE(C<=O,C,O,1,0),COLORCECE00;STICKLINE(C<=O,H,L,0,0),COLORFFFF00;ZA1:=EMA(C,25);ZA2:=EMA(ZA1,45);ZB1:=EMA(C,65);ZB2:=EMA(ZB1,45);DIFF:=(ZA1+ZB2)/2;DEA:=(ZA2+ZB1)/2;KA0:=(HHV(C,45)-LLV(C,45))/45;KA1:=SMA(C,3,1);KA2:=SMA(C-KA0*3,3,1);KA3:=SMA(KA1-KA0*3,3,1);SC:=100*(CLOSE-MA(CLOSE,80));SC1:=EMA(SC,5);SC2:=EMA(SC,21);长期策略:SC1>=SC2,NODRAW;次级策略:DIFF>=DEA,NODRAW;短期策略:KA2>=KA3,NODRAW;短期拐点:REF(短期策略,1)=0 AND 短期策略=1,NODRAW;长期趋势:ZB2,COLORYELLOW,LINETHICK3;次级趋势:DIFF,NODRAW;短期趋势:KA2,NODRAW;IF(DIFF>=DEA,DIFF,DRAWNULL),LINETHICK3,COLORRED;IF(DIFF<DEA,DIFF,DRAWNULL),LINETHICK1,COLORBLUE;IF(KA2>=KA3,KA2,DRAWNULL)COLORMAGENTA,LINETHICK3;IF(KA2<KA3,KA2,DRAWNULL),LINETHICK1,COLORGREEN;CSAR:=SAR(10,2,20);持股:=IF(CSAR<=L,CSAR,0);涅磐:=EMA(SLOPE(C,21)*20+C,42);般若:=EMA(C,5);VAR1:=(C+H+O+L)/4;卖出:=XMA(VAR1,20)*(1+80/1000);买入:=XMA(VAR1,32)*(1-100/1000);菩提:=买入+(卖出-买入)*2/3;{此函数仅做参考线,为提前趋势预测线,上涨途中向下见顶,下跌途中向上见底};开悟:=IF(般若>=REF(般若,1),般若,DRAWNULL);抛物线转向:=CROSS(L,CSAR) AND 开悟>0 AND H<菩提 AND 持股>0 AND H>涅磐;DRAWICON(抛物线转向,(H),16);{趋势底};般:=XMA(CLOSE,7);若:=MEMA(CLOSE,3);趋势延伸:=短期拐点 AND 菩提>H AND NOT(抛物线转向);DRAWICON(趋势延伸,H,4);DRAWICON(LONGCROSS(若,般,3) AND H>菩提,H,19);DRAWICON(BARSLAST(LONGCROSS(若,般,3) AND H>菩提)=1,H,2);

通达信指标公式

  以上是本站关于“高点压力出现(通达信)”的详细内容介绍,更多精彩请收藏本站。

编辑:赵立赢