操盘手之家是国内最好的最全面的股票知识学习网站,提供股票基础知识,股票入门书籍和视频教程,技术指标教程等。
操盘手之家 > 指标公式 > 通达信公式 > 底部机会来临通达信指标源码

底部机会来临通达信指标源码   

来源:操盘手之家  阅读: 2020年11月04日 21:46:20

VAR2:=REF(LOW,1);VAR3:=SMA(ABS(LOW-VAR2),13,1)/SMA(MAX(LOW-VAR2,0),13,1)*100;VAR4:=EMA(IF(CLOSE*1.2,VAR3*13,VAR3/13),13);VAR5:=LLV(LOW,34);VAR6:=HHV(VAR4,34);VAR7:=IF(LLV(LOW,55),1,0);VAR8:=EMA(IF(LOW<=VAR5,(VAR4+VAR6*2)/2,0),3)/618*VAR7;VAR9:=EMA(CLOSE,5);VAR10:=(CLOSE-MA(CLOSE,34))/MA(CLOSE,34)*(-10);VAR11:=EMA(IF(LOW<=VAR5,(VAR4+VAR6*2)/2,0),3)/618*VAR7*(-1);VAR12:=EMA(CLOSE,5)*(-1);STICKLINE(VAR8>REF(VAR8,1),0,VAR8,6,1),COLOR10FFFF,LINETHICK1;备钱:IF(VAR8>REF(VAR8,1),0,VAR8),COLOR0FFFFF;STICKLINE(VAR11>REF(VAR11,1),0,VAR11,6,1),COLORFFF810;界:0,COLORFFFFFF,LINETHICK1;XL1:=MA(LOW,2)*0.96;XL2:=MA(LOW,26)*0.85;XL3:=REF(XL1,1)<XL2 AND REF(XL1,1)<XL1 AND REF(XL1,1)<REF(XL1,2);STICKLINE(XL3,0,VAR8*3,8,0),COLORRED;启动:IF(XL3,0,VAR8*3),COLORRED;

散户:= EMA(((2*CLOSE+HIGH+LOW)/4-LLV(LOW,5))/(HHV(HIGH,4)-LLV(LOW,5))*100,4);庄家:= EMA(0.667*REF(散户,1)+0.333*散户,2);DRAWTEXT(CROSS(散户,庄家) AND 散户<30,15,'低进'),COLOR00FF00;DRAWTEXT(CROSS(散户,庄家) AND 散户<30,7,'●'),COLORFFFFFF;极品底:IF((MA(C,5)-C)/C>0.04 AND (MA(C,10)-MA(C,5))/MA(C,5)>0.04,23,0),LINETHICK1,COLORFF00FF;DRAWICON(极品底=23,23,1),LINETHICK2,COLORFFFFFF;RSV:=(((CLOSE - LLV(LOW,9)) / (HHV(HIGH,9) - LLV(LOW,9))) * 100);K:=SMA(RSV,3,1);D:=SMA(K,3,1);J:=3*K-2*D;X:=LLV(J,2)=LLV(J,8);DRAWTEXT(CROSS(J,REF(J+0.01,1)) AND X AND J<19,3,'低进'),COLORFFFF00;DRAWTEXT(CROSS(J,REF(J+0.01,1)) AND X AND J<19,17,'▲'),COLORRED;DRAWTEXT(CROSS(J,REF(J+0.01,1)) AND X AND J<19,16,'▲'),COLORRED;DRAWTEXT(CROSS(J,REF(J+0.01,1)) AND X AND J<19,5,'↑'),COLORRED;QVAR1A:=((HHV(HIGH,21)-CLOSE)/(HHV(HIGH,21)-LLV(LOW,21)))*(100)-10;QVAR1B:=((CLOSE-LLV(LOW,21))/(HHV(HIGH,21)-LLV(LOW,21)))*(100);QVAR1C:=SMA(QVAR1B,13,8);QVAR1D:=SMA(QVAR1A,21,8);机会来临:=SMA(QVAR1C,13,8),COLORRED;AAS:=FILTER((COUNT((机会来临-QVAR1D<(-65)),3)=3),34);波段买点:IF(AAS,15,0),COLORFFFFFF,STICK,LINETHICK1;DRAWTEXT(波段买点,17,'波段买'),COLORFFFFFF;控盘:= (EMA(EMA(CLOSE,9),9)-REF(EMA(EMA(CLOSE,9),9),1))/REF(EMA(EMA(CLOSE,9),9),1)*400;A10:=CROSS(控盘,0);开始控盘:IF(A10,13,0),LINETHICK1,COLORYELLOW;VAR15:=((HHV(H,21)-C)/(HHV(H,21)-LLV(L,21)))*100-10;VAR25:=((C-LLV(L,21))/(HHV(H,21)-LLV(L,21)))*100;VAR35:=SMA(VAR25,13,8);VAR45:=SMA(VAR15,21,8);X2:=CEILING(SMA(VAR35,13,8));X1:=X2-VAR45 ;底部选股:IF(X2-VAR45<(-80),30,0),COLORCYAN;R1:=(((MA(CLOSE,5))-CLOSE)/CLOSE>3/100);R2:=((MA(CLOSE,10))-(MA(CLOSE,5)))/(MA(CLOSE,5))>0.03;R3:=(LLV(CLOSE,20)=LLV(CLOSE,30));大:=(R1 AND R2 AND R3);大A:=FILTER(大,5);买:STICKLINE(大A,20,0,2,0),COLORYELLOW;跟着庄家进:=IF(大A,1,0),COLORRED;RG1:=MA(CLOSE,27);RG2:=((CLOSE - RG1)/(RG1))*(100);RG3:=MA(RG2,2);RG4:=BARSLAST((CROSS((-10),RG3) = 1));RG5:=(RG3 < (-10)) AND (RG4 > 3);V1:=C/REF(MA(C,36),6)*10;RF1:=EMA(CLOSE,3);RF2:=((SMA(MAX((CLOSE - RF1),0),9,1) / SMA(ABS((CLOSE - RF1)),9,1)) * 100);RF3:=((100 - (3 * SMA((((CLOSE - LLV(LOW,75)) / (HHV(HIGH,75) - LLV(LOW,75))) * 100),30,1))) + (2 * SMA(SMA((((CLOSE - LLV(LOW,75)) / (HHV(HIGH,75) - LLV(LOW,75))) * 100),30,1),21,1)));RF4:=((100 - (3 * SMA((((OPEN - LLV(LOW,75)) / (HHV(HIGH,75) - LLV(LOW,75))) * 100),30,1))) + (2 * SMA(SMA((((OPEN - LLV(LOW,75)) / (HHV(HIGH,75) - LLV(LOW,75))) * 100),30,1),21,1)));RF5:=((((HHV(HIGH,21) - CLOSE) / (HHV(HIGH,21) - LLV(LOW,21))) * 100) - 10);RF6:=(((CLOSE - LLV(LOW,21)) / (HHV(HIGH,21) - LLV(LOW,21))) * 100);RF7:=SMA(SMA(RF6,16,8),25,8)-SMA(RF5,30,8);K0:=IF((RF2< 14) AND L<REF(L,1) AND V1<8.8 AND RF7<-65,50,0);K1:=IF(K0>1 AND C>O,50,0),STICK,COLOR10FFFF,LINETHICK3;K2:=IF(K0>1 AND C/L>1.045,50,0);K3:=IF(REF(K0,1)>0 AND K0=0,10,0);准备1:IF(K0>3 AND RG5=0,16,0),STICK,COLOR10FFFF,LINETHICK3;K4:=IF(MAX(MAX(K1,K2),K3) AND REF(准备1,1)>0,30,0);进场1:IF(K4>0 AND REF(K4,1)=0,30,0),STICK,COLOR00FF00,LINETHICK3;DRAWTEXT(进场1,28,'进场1'),COLOR10FF10;DRAWTEXT(准备1,12,'准备1'),COLOR10FFFF;准备2:IF(K0>3 AND RG5>0,16,0),STICK,COLORFF00FF,LINETHICK3;K5:=IF(MAX(MAX(K1,K2),K3) AND REF(准备2,1)>0,30,0);进场2:IF(K5>1 AND REF(K5,1)=0,30,0),STICK,COLORFFFF00,LINETHICK3;DRAWTEXT(进场2,28,'进场2'),COLORFFFF00;DRAWTEXT(准备2,12,'准备2'),COLORFF00FF;红箭头上涨:EMA(IF(L<= LLV(L,30),SMA(ABS(L-REF(L,1)),40,1)/SMA(MAX(L-REF(L,1),0),30,1),0),3)*15,STICK,COLORYELLOW,LINETHICK2;DRAWICON(红箭头上涨>25,30,1);LC:=REF(CLOSE,1);RSI:=((SMA(MAX(CLOSE - LC,0),4.1,1))/(SMA(ABS(CLOSE - LC),4.1,1)))*(100);火山反转底部:(CROSS(RSI,11))*(25),COLORGREEN;VAR37:=(CLOSE-MA(CLOSE,6))/MA(CLOSE,6)*100;VAR38:=(CLOSE-MA(CLOSE,12))/MA(CLOSE,12)*100;VAR39:=(CLOSE-MA(CLOSE,24))/MA(CLOSE,24)*100;VAR3A:=(VAR37+2*VAR38+3*VAR39)/6;VAR3B:=MA(VAR3A,3);波段金牌:IF(VAR3B<-6,0,-25);

通达信指标公式

  以上是本站关于“底部机会来临(通达信)”的详细内容介绍,更多精彩请收藏本站。

编辑:吕氏春秋