操盘手之家是国内最好的最全面的股票知识学习网站,提供股票基础知识,股票入门书籍和视频教程,技术指标教程等。
操盘手之家 > 指标公式 > 通达信公式 > {斜率}追涨先锋通达信指标源码

{斜率}追涨先锋通达信指标源码   

来源:操盘手之家  阅读: 2020年11月01日 16:38:02

{斜率3.7.15}XX51:=XMA((EXPMA(CLOSE,3)-REF(EXPMA(CLOSE,3),1))*100/REF(EXPMA(CLOSE,3),1),4),LINETHICK2,COLORYELLOW;XX101:=XMA((EXPMA(CLOSE,7)-REF(EXPMA(CLOSE,7),1))*100/REF(EXPMA(CLOSE,7),1),7),LINETHICK2,COLORBLUE;XX2001:=XMA((EXPMA(CLOSE,15)-REF(EXPMA(CLOSE,15),1))*100/REF(EXPMA(CLOSE,15),1),20);

AA11:=XX2001>=0.2 AND REF(XX2001,1)<XX2001 AND XX51> XX101 AND XX101>XX2001AND REF(XX51,2)<REF(XX101,2) AND REF(XX101,2)< REF(XX2001,2) ;XX2021:=XMA((EXPMA(CLOSE,15)-REF(EXPMA(CLOSE,15),1))*100/REF(EXPMA(CLOSE,15),1),22);AA21:=XX2021>=0.2 AND REF(XX2001,1)<XX2001 AND XX51> XX101 AND XX101>XX2021AND REF(XX51,2)<REF(XX101,2) AND REF(XX101,2)< REF(XX2021,2) ;XX2041:=XMA((EXPMA(CLOSE,15)-REF(EXPMA(CLOSE,15),1))*100/REF(EXPMA(CLOSE,15),1),24);AA31:=XX2041>=0.2 AND REF(XX2001,1)<XX2001 AND XX51> XX101 AND XX101>XX2041AND REF(XX51,2)<REF(XX101,2) AND REF(XX101,2)< REF(XX2041,2) ;XX2061:=XMA((EXPMA(CLOSE,15)-REF(EXPMA(CLOSE,15),1))*100/REF(EXPMA(CLOSE,15),1),26);AA41:=XX2061>=0.2 AND REF(XX2001,1)<XX2001 AND XX51> XX101 AND XX101>XX2061AND REF(XX51,2)<REF(XX101,2) AND REF(XX101,2)< REF(XX2061,2) ;

XX2070:=XMA((EXPMA(CLOSE,15)-REF(EXPMA(CLOSE,15),1))*100/REF(EXPMA(CLOSE,15),1),20);AA70:=XX2070>=0.2 AND REF(XX2070,1)<XX2070 AND CROSS(XX101,XX2070)AND CROSS(REF(XX51,1),REF(XX2070,1));

XX20710:=XMA((EXPMA(CLOSE,15)-REF(EXPMA(CLOSE,15),1))*100/REF(EXPMA(CLOSE,15),1),23);AA710:=XX20710>=0.2 AND REF(XX20710,1)<XX20710 AND CROSS(XX101,XX20710)AND CROSS(REF(XX51,1),REF(XX20710,1));

XX20720:=XMA((EXPMA(CLOSE,15)-REF(EXPMA(CLOSE,15),1))*100/REF(EXPMA(CLOSE,15),1),26);AA720:=XX20720>=0.2 AND REF(XX20720,1)<XX20720 AND CROSS(XX101,XX20720)AND CROSS(REF(XX51,1),REF(XX20720,1));

XX2080:=XMA((EXPMA(CLOSE,15)-REF(EXPMA(CLOSE,15),1))*100/REF(EXPMA(CLOSE,15),1),20);AA80:=XX2080>=0.2 AND REF(XX2080,1)<XX2080 AND CROSS(XX101,XX2080)AND CROSS(XX51,XX2080);XX20810:=XMA((EXPMA(CLOSE,15)-REF(EXPMA(CLOSE,15),1))*100/REF(EXPMA(CLOSE,15),1),23);AA810:=XX20810>=0.2 AND REF(XX20810,1)<XX20810 AND CROSS(XX101,XX20810)AND CROSS(XX51,XX20810);

XX20820:=XMA((EXPMA(CLOSE,15)-REF(EXPMA(CLOSE,15),1))*100/REF(EXPMA(CLOSE,15),1),26);AA820:=XX20820>=0.2 AND REF(XX20820,1)<XX20820 AND CROSS(XX101,XX20820)AND CROSS(XX51,XX20820);

{VARV01:=HIGH/REF(LOW,1)> 0.18 AND ABS(HHV(HIGH,10)-LLV(LOW,10))/CLOSE>0.06 AND ABS(CLOSE-REF(CLOSE,50))/CLOSE> 0.2 AND REF(C,1)<REF(C,2)AND REF(C,2)<REF(C,3) AND "ZXNH"; }

斜率:AA11 OR AA21 OR AA31 OR AA41 OR AA70 OR AA710 OR AA720 OR AA80 OR AA810OR AA820 ,COLORFF00FF,LINETHICK1;

{斜率356}X5:=EXPMA(CLOSE,3);X10:=EXPMA(CLOSE,5);X20:=EXPMA(CLOSE,6);五日斜率:=(X5-REF(X5,1))*100/REF(X5,1);十日斜率:=(X10-REF(X10,1))*100/REF(X10,1),LINETHICK1;二十斜率:=(X20-REF(X20,1))*100/REF(X20,1),LINETHICK1,COLORWHITE;

XX200:XMA(二十斜率,10),LINETHICK1;AA1:=XX200>=0.2 AND REF(XX200,1)<XX200 AND XMA(五日斜率,4)> XMA(十日斜率,7) AND XMA(十日斜率,7)>XX200 AND REF(XMA(五日斜率,4),2)<REF(XMA(十日斜率,7),2) AND REF(XMA(十日斜率,7),2)<REF(XX200,2) ;XX202:XMA(二十斜率,11),LINETHICK1;AA2:=XX202>=0.2 AND REF(XX200,1)<XX200 AND XMA(五日斜率,4)> XMA(十日斜率,7) AND XMA(十日斜率,7)>XX202AND REF(XMA(五日斜率,4),2)<REF(XMA(十日斜率,7),2) AND REF(XMA(十日斜率,7),2)< REF(XX202,2) ;XX204:XMA(二十斜率,12),LINETHICK1;AA3:=XX204>=0.2 AND REF(XX200,1)<XX200 AND XMA(五日斜率,4)> XMA(十日斜率,7) AND XMA(十日斜率,7)>XX204AND REF(XMA(五日斜率,4),2)<REF(XMA(十日斜率,7),2) AND REF(XMA(十日斜率,7),2)< REF(XX204,2) ;XX206:XMA(二十斜率,13),LINETHICK1;AA4:=XX206>=0.2 AND REF(XX200,1)<XX200 AND XMA(五日斜率,4)> XMA(十日斜率,7) AND XMA(十日斜率,7)>XX206AND REF(XMA(五日斜率,4),2)<REF(XMA(十日斜率,7),2) AND REF(XMA(十日斜率,7),2)< REF(XX206,2) ;

XX207:XMA(二十斜率,10),LINETHICK1;AA7:=XX207>=0.2 AND REF(XX207,1)<XX207 AND CROSS(XMA(十日斜率,7),XX207)AND CROSS(REF(XMA(五日斜率,4),1),REF(XX207,1));

XX2071:XMA(二十斜率,12),LINETHICK1;AA71:=XX2071>=0.2 AND REF(XX2071,1)<XX2071 AND CROSS(XMA(十日斜率,7),XX2071)AND CROSS(REF(XMA(五日斜率,4),1),REF(XX2071,1));

XX2072:XMA(二十斜率,14);AA72:=XX2072>=0.2 AND REF(XX2072,1)<XX2072 AND CROSS(XMA(十日斜率,7),XX2072)AND CROSS(REF(XMA(五日斜率,4),1),REF(XX2072,1));

XX208:XMA(二十斜率,10),LINETHICK1;AA8:=XX208>=0.2 AND REF(XX208,1)<XX208 AND CROSS(XMA(十日斜率,7),XX208)AND CROSS(XMA(五日斜率,4),XX208);XX2081:XMA(二十斜率,12),LINETHICK1;AA81:=XX2081>=0.2 AND REF(XX2081,1)<XX2081 AND CROSS(XMA(十日斜率,7),XX2081)AND CROSS(XMA(五日斜率,4),XX2081);

XX2082:XMA(二十斜率,14);AA82:=XX2082>=0.2 AND REF(XX2082,1)<XX2082 AND CROSS(XMA(十日斜率,7),XX2082)AND CROSS(XMA(五日斜率,4),XX2082);

斜率356:(AA1 OR AA2 OR AA3 OR AA4 OR AA7 OR AA71 OR AA72 OR AA8 OR AA81 OR AA82),COLORFFFFFF,LINETHICK1;

DRAWTEXT(AA1=1,0.050,'A'),COLORRED;DRAWTEXT(AA2=1,0.00,'B'),COLORRED;DRAWTEXT(AA3=1,0.00,'C'),COLORRED;DRAWTEXT(AA4=1,0.00,'D'),COLORRED;DRAWTEXT(AA7=1,0.00,'E'),COLORRED;DRAWTEXT(AA71=1,0.00,'A6'),COLORRED;DRAWTEXT(AA72=1,0.00,'A7'),COLORRED;DRAWTEXT(AA8=1,0.00,'A8'),COLORRED;DRAWTEXT(AA81=1,0.05,'A9'),COLORRED;DRAWTEXT(AA82=1,0.00,'A10'),COLORRED;

通达信指标公式

  以上是本站关于“{斜率}追涨先锋(通达信)”的详细内容介绍,更多精彩请收藏本站。

编辑:刘一手