操盘手之家是国内最好的最全面的股票知识学习网站,提供股票基础知识,股票入门书籍和视频教程,技术指标教程等。
您现在的位置:操盘手之家 > 股票软件 > 上海宏润建设-000050股吧-通达信十指金叉 改进版源码

上海宏润建设-000050股吧-通达信十指金叉 改进版源码   

来源:花都股票学习网  阅读: 2019年11月11日 10:51:57

  上海宏润建设-000050股吧-通达信十指金叉 改进版源码以下是通达信十指金叉 改进版源码(注:若无源码的请联系本站客服索取或下载附件自行导入软件),,本公式由花都股票网证券资深从业人员收集整理发布,欢迎广大股民朋友下载使用!

  N1:=3;N2:=5;N3:=9;N4:=13;N5:=21;N6:=34;

   DIFF:=EMA(CLOSE,N3)-EMA(CLOSE,N4);

   DEA:=EMA(DIFF,N2);

   DRAWICON(DIFF>DEA,1,1);

   X1:DRAWICON(DIFF<DEA,1,2);

   DRAWTEXT(ISLASTBAR=1,1,'.MACD'),COLORFFFFFF;

   A1:=DIFF>DEA;

   RSV1:=(CLOSE-LLV(LOW,N3))/(HHV(HIGH,N3)-LLV(LOW,N3))*100;

   K:=SMA(RSV1,N1,1);

   D:=SMA(K,N1,1);

   DRAWICON(K>D,2,1);

   X2:DRAWICON(K<D,2,2);

   DRAWTEXT(ISLASTBAR=1,2,'.KDJ'),COLORFFFFFF;

   A2:=K>D;

   LC:=REF(CLOSE,1);

   RSI1:=(SMA(MAX(CLOSE-LC,0),N2,1))/(SMA(ABS(CLOSE-LC),N2,1))*100;

   RSI2:=(SMA(MAX(CLOSE-LC,0),N4,1))/(SMA(ABS(CLOSE-LC),N4,1))*100;

   DRAWICON(RSI1>RSI2,3,1);

   X3:DRAWICON(RSI1<RSI2,3,2);

   DRAWTEXT(ISLASTBAR=1,3,'.RSI'),COLORFFFFFF;

   A3:=RSI1>RSI2;

   RSV:=-(HHV(HIGH,N4)-CLOSE)/(HHV(HIGH,N4)-LLV(LOW,N4))*100;

   LWR1:=SMA(RSV,N1,1);

   LWR2:=SMA(LWR1,N1,1);

   DRAWICON(LWR1>LWR2,4,1);

   X4:DRAWICON(LWR1<LWR2,4,2);

   DRAWTEXT(ISLASTBAR=1,4,'.LW&R'),COLORFFFFFF;

   A4:=LWR1>LWR2;

   BBI:=(MA(CLOSE,N1)+MA(CLOSE,N2)+MA(CLOSE,N3)+MA(CLOSE,N4))/4;

   DRAWICON(CLOSE>BBI,5,1);

   X5:DRAWICON(CLOSE<BBI,5,2);

   DRAWTEXT(ISLASTBAR=1,5,'.BBI'),COLORFFFFFF;

   A5:=CLOSE>BBI;

   MTM:=CLOSE-REF(CLOSE,1);

   MMS:=100*EMA(EMA(MTM,N2),N1)/EMA(EMA(ABS(MTM),N2),N1);

   MMM:=100*EMA(EMA(MTM,N4),N3)/EMA(EMA(ABS(MTM),N4),N3);

   DRAWICON(MMS>MMM,6,1);

   X6:DRAWICON(MMS<MMM,6,2);

   DRAWTEXT(ISLASTBAR=1,6,'.ZLMM'),COLORFFFFFF;

   A6:=MMS>MMM;

   BIAS:=(C-MA(C,N2))/MA(C,N2);

   DIF:=(BIAS-REF(BIAS,16));

   DBCD:=SMA(DIF,76,1);

   MM:=MA(DBCD,5);

   DRAWICON(DBCD>MM ,7,1);

   X7:DRAWICON(DBCD<MM,7,2);

   DRAWTEXT(ISLASTBAR=1,7,'.DBCD'),COLORFFFFFF;

   A7:=DBCD>MM;

  持股:=3*SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100,5,1)-2*SMA(SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100,5,1),3,1),LINETHICK0,COLORRED;

  支撑:=LLV(持股,3),LINETHICK0,COLOR00FFFF;

  下跌:=MA(持股,12),COLOR6B8E23,LINETHICK0;{上面三行去了等号指标上面就有参数但图形去变了样}

  转向:=CROSS(持股,下跌){ AND 下跌<30};

   MA1:=MA(持股,5);

  向下:=CROSS(MA1,持股) AND MA1>80;

   DRAWICON(持股>下跌 ,8,1);

   X8:DRAWICON(持股<下跌,8,2);

   DRAWTEXT(ISLASTBAR=1,8,'.CGZ'),COLORFFFFFF;

   A8:=持股>下跌;

  MT:=C-REF(C,1);

   ZLGJ:=100*EMA(EMA(MT,N3),N3)/EMA(EMA(ABS(MT),N3),N3);

   MAZL:=MA(ZLGJ,5);

   DRAWICON(ZLGJ>MAZL,9,1);

   X9:DRAWICON(ZLGJ<MAZL,9,2);

   A9:=ZLGJ>MAZL;

   DRAWTEXT(ISLASTBAR=1,9,'.ZLGJ'),COLORFFFFFF;

   PJJ:=DMA((HIGH+LOW+CLOSE*2)/4,0.9);

   JJ:=REF(EMA(PJJ,3),1);

   QJJ:=VOL/((HIGH-LOW)*2-ABS(CLOSE-OPEN));

   XVL:=IF(CLOSE>OPEN,QJJ*(HIGH-LOW),IF(CLOSE<OPEN,QJJ*(HIGH-OPEN+CLOSE-LOW),VOL/2))+IF(CLOSE>OPEN,0-QJJ*(HIGH-CLOSE+OPEN-LOW),IF(CLOSE<OPEN,0-QJJ*(HIGH-LOW),0-VOL/2));

   HSL:=(XVL/20)/1.15;

  攻击流量:=((HSL*0.55+(REF(HSL,1)*0.33))+(REF(HSL,2)*0.22));

   GJJ:=EMA(攻击流量,8);

   LLJX:=EMA(攻击流量,3);

  资金流量:=LLJX,LINETHICK0,COLOR0000FF;

   DRAWICON(资金流量>0,10,1);

   X10:DRAWICON(资金流量<0,10,2);

  

  本站关于“上海宏润建设-000050股吧-通达信十指金叉 改进版源码”的内容基本完结,更多精彩敬请关注!

编辑:股海冲浪板