操盘手之家是国内最好的最全面的股票知识学习网站,提供股票基础知识,股票入门书籍和视频教程,技术指标教程等。
您现在的位置:操盘手之家 > 股票软件 > 财经1158:通达信观音点化公式副图源码K线图悟道股道

财经1158:通达信观音点化公式副图源码K线图悟道股道   

来源:花都股票学习网  阅读: 2019年11月06日 11:14:31

  以下是通达信观音点化公式副图源码K线图悟道股道(注:若无源码的请联系本站客服索取或下载附件自行导入软件),,本公式由花都股票网证券资深从业人员收集整理发布,欢迎广大股民朋友下载使用!

  通达信公式观音点化

  DRAWGBK(C>0,RGB(000,80,120),RGB(250,250,250),0,0,0);

  {大盘状态}

  X:=IF(PERIOD=5,2,5);

  PLOYLINE(C,X),COLORFFFFFF,LINETHICK3;

  P综价:=(INDEXH+INDEXL+INDEXO+3*INDEXC)/6;

  P多空线:=(WMA(P综价,2)+WMA(P综价,4)+WMA(P综价,6)+WMA(P综价,8))/4;

  P短线多空对峙位:=(P多空线-LLV(P多空线,30))/(HHV(P多空线,30)-LLV(P多空线,30))*10;

  PK短:=SMA(P短线多空对峙位,3,1);

  PD短:=SMA(PK短,3,1);

  PJ短:=3*PK短-2*PD短;

  PJ短A:=IF(PJ短>10,10,PJ短);

  PJ短B:=IF(PJ短A<0,0,PJ短A);

  P均J短B:=SMA(PJ短B,2,1);

  大盘福缘:P均J短B>=REF(P均J短B,1),NODRAW;

  大盘缘尽:NOT(大盘福缘),NODRAW;

  {弱态描述}

  苦难众生:EMA((1-WINNER(C)),21)*10,COLOR008800;

  金色圣泉:HHV(苦难众生,3)>苦难众生,COLOR0099DD,LINETHICK0;

  DRAWBAND(IF(金色圣泉,HHV(苦难众生,3),0),RGB(220,183,35),0,0);

  观音湖:IF(苦难众生<X,X,DRAWNULL),COLORFFFFFF,LINETHICK1;

  DRAWBAND(IF(观音湖,X,DRAWNULL),RGB(159,159,0),苦难众生,DRAWNULL);

  DRAWBAND(IF(苦难众生>0,苦难众生,0),RGB(0,100,50),0,0);

  DRAWBAND(IF(苦难众生>9.5,苦难众生,9.5),RGB(255,255,0),IF(苦难众生<9.5,DRAWNULL,苦难众生),0);

  涨二成仍套比:=(1-WINNER(1.2*C))*10;

  涨二成五仍套比:=(1-WINNER(1.25*C))*10;

  涨三成仍套比:=(1-WINNER(1.3*C))*10; 

  涨四成仍套比:=(1-WINNER(1.4*C))*10;

  涨五成仍套比:=(1-WINNER(1.5*C))*10;

  DRAWBAND(涨二成仍套比,RGB(125,255,125),0,0);

  DRAWBAND(涨二成五仍套比,RGB(50,255,50),0,0);

  DRAWBAND(涨三成仍套比,RGB(0,200,0),0,0);

  DRAWBAND(涨四成仍套比,RGB(0,150,0),0,0);

  DRAWBAND(涨五成仍套比,RGB(0,100,0),0,0);

  {大底判断}

  佛珠:(C-MA(C,34))/MA(C,34)<-0.382 OR C/MA(C,60)<0.618,COLORRED,LINETHICK0;

  {长线波动与短线波动的描述}

  综价:=(H+L+O+3*C)/6;

  多空线:=(WMA(综价,2)+WMA(综价,4)+WMA(综价,8)+WMA(综价,16))/4;

  长线多空对峙位:=(多空线-LLV(多空线,120))/(HHV(多空线,120)-LLV(多空线,120))*10;

  K长:=SMA(长线多空对峙位,21,1);

  D长:=SMA(K长,21,1);

  J长:=3*K长-2*D长;

  J长A:=IF(J长>10,10,J长);

  J长B:=IF(J长A<0,0,J长A);

  均J长B:=SMA(J长B,2,1);

  虔心向佛:均J长B>=REF(均J长B,1),COLORFF63DB,LINETHICK0;

  短线多空对峙位:=(多空线-LLV(多空线,30))/(HHV(多空线,30)-LLV(多空线,30))*10;

  K短:=SMA(短线多空对峙位,3,1);

  D短:=SMA(K短,3,1);

  J短:=3*K短-2*D短;

  J短A:=IF(J短>10,10,J短);

  J短B:=IF(J短A<0,0,J短A);

  均J短B:=SMA(J短B,2,1);

  观音指点:CROSS(均J短B,REF(均J短B,1)) AND K短<5,COLORYELLOW,LINETHICK0;

  慈航普渡:FILTER(苦难众生<X AND COUNT(苦难众生<X,2)=1,5);

  {强势描述}

  N1:=IF(PERIOD=5,13,IF(PERIOD=6,4,2));

  N2:=IF(PERIOD=5,21,IF(PERIOD=6,6,3));

  N3:=IF(PERIOD=5,34,IF(PERIOD=6,8,4));

  乖离13:=10-WMA((C-MA(C,N1))/MA(C,N1),5)*10;

  乖离21:=10-WMA((C-MA(C,N2))/MA(C,N2),5)*10;

  乖离34:=10-WMA((C-MA(C,N3))/MA(C,N3),5)*10;

  可羽化:=乖离13<10;

  羽化:可羽化 AND 乖离13<REF(乖离13,1),LINETHICK0,COLORFF76FF;

  可飞升:=乖离21<10;

  飞升:可飞升 AND 乖离21<REF(乖离21,1) AND 乖离21<乖离13,LINETHICK0,COLOR00389A;

  可成仙:=乖离34<10;

  成仙:乖离34<REF(乖离34,1) AND 可成仙 AND 乖离34<乖离21,LINETHICK0,COLOR00BEFF;

  DRAWBAND(10,RGB(230,230,0),IF(可成仙,乖离34,10),0);

  DRAWBAND(10,RGB(200,200,0),IF(成仙,乖离34,10),0);

  DRAWBAND(10,RGB(128,0,64),IF(可飞升,乖离21,10),0);

  DRAWBAND(10,RGB(255,128,255),IF(可羽化,乖离13,10),0);

  {画图}

  DRAWICON(佛珠,1.5,13);

  IF(虔心向佛,均J长B,DRAWNULL),COLOR990099,LINETHICK2,DOTLINE;

  IF(NOT(虔心向佛),均J长B,DRAWNULL),COLOR888888,LINETHICK2,DOTLINE;

  福缘:IF(均J短B>=REF(均J短B,1),均J短B,DRAWNULL),COLOR0000C8,LINETHICK3;

  缘尽:IF(均J短B<=REF(均J短B,1),均J短B,DRAWNULL),COLORFFFFFF,LINETHICK3;

  DRAWICON(观音指点,REF(均J短B,1)+0.5,11);

  DRAWTEXT(慈航普渡,X+1,'慈航普渡'),COLOR0000FF;

  IF(大盘福缘,P均J短B,DRAWNULL),COLOR0033FF,CIRCLEDOT;

  IF(大盘缘尽,P均J短B,DRAWNULL),COLORCCCCCC,CIRCLEDOT;

  {PLOYLINE(大盘缘尽 AND 福缘,均J短B),COLORMAGENTA,LINETHICK2;}

  {版权信息}

  {DRAWTEXT((SYSPARAM(2) = BARPOS),C,'WHK-WXW编辑V8.0808'),ALIGN5,COLORFFFF00;};

  

  本站关于“财经1158:通达信观音点化公式副图源码K线图悟道股道”的内容基本完结,更多精彩敬请关注!

编辑:股海冲浪板