操盘手之家是国内最好的最全面的股票知识学习网站,提供股票基础知识,股票入门书籍和视频教程,技术指标教程等。
您现在的位置:操盘手之家 > 股票软件 > 600125资金流向:通达信中枢缠绵主图指标源码

600125资金流向:通达信中枢缠绵主图指标源码   

来源:花都股票学习网  阅读: 2019年11月05日 13:21:06

  以下是通达信中枢缠绵主图指标源码(注:若无源码的请联系本站客服索取或下载附件自行导入软件),,本公式由花都股票网证券资深从业人员收集整理发布,欢迎广大股民朋友下载使用!

  MA5:EMA(C,5),POINTDOT;

   MA10:MA(C,10),COLORYELLOW,LINETHICK2,POINTDOT;

  黄金线:(EMA(C,18)),COLORYELLOW;

  黄金线1:(EMA(C,15)),COLOR0000FF;

   MA60:MA(C,60),COLORRED,POINTDOT;

   MA90:MA(CLOSE,90),COLORD89837,POINTDOT;

   N1:=10;N2:=10;DISP:=2;

   K:=IF(PERIOD=5,1,{日}

  IF(PERIOD=6,1,{周}

  IF(PERIOD=7,1,{月}

  IF(PERIOD=8,1,{多分钟}

  IF(PERIOD=9,1,{多日}

  IF(PERIOD=10,1,{季}

  IF(PERIOD=11,2,{年}

  IF(PERIOD=4,1,{60F}

   IF(PERIOD=3,1,{30F}

   IF(PERIOD=2,1,{15F}

   IF(PERIOD=1,1{5F},1{1F})))))))))))/10;

   P1:=PEAK(1,K*N1,1);

   P2:=PEAK(1,K*N1,2);

   WP1:=PEAKBARS(1,K*N1,1);

   WP2:=PEAKBARS(1,K*N1,2);

   T1:=TROUGH(2,K*N2,1);

   T2:=TROUGH(2,K*N2,2);

   WT1:=TROUGHBARS(2,K*N2,1);

   WT2:=TROUGHBARS(2,K*N2,2);

   TJ1:=P1>T1 AND P2>T2 ;

   ZD:=MAX(T1,T2);

   ZG:=MIN(P1,P2);

   LL:=MIN(T1,T2);

   HH:=MAX(P1,P2);

   TJ2:=FILTER(ZG>ZD,2);

   TJ3:=ZG=REF(ZG,BARSLAST(TJ2)) OR ZD=REF(ZD,BARSLAST(TJ2));

   TJ4:=TJ1&&TJ2&&NOT(TJ3);

   TJ5:=BETWEEN(ZD,REF(ZD,REF(BARSLAST(TJ4),1)),REF(ZG,REF(BARSLAST(TJ4),1)));

   TJ6:=BETWEEN(ZG,REF(ZD,REF(BARSLAST(TJ4),1)),REF(ZG,REF(BARSLAST(TJ4),1)));

   TJ7:=ZG>REF(ZG,REF(BARSLAST(TJ4),1))&&ZD<REF(ZD,REF(BARSLAST(TJ4),1));

   TJ8:=TJ4&&NOT(TJ5 OR TJ6 OR TJ7);

   ZSD:=IF(TJ8,ZD,DRAWNULL);

   ZSG:=IF(TJ8,ZG,DRAWNULL);

   ZSH:=IF(TJ8,HH,DRAWNULL);

   ZSL:=IF(TJ8,LL,DRAWNULL);

   STICKLINE(TJ8,ZSH,ZSL,0,-1),COLORMAGENTA;

   STICKLINE(TJ8,ZSD,ZSG,IF(DISP=1,3,0),1),COLORMAGENTA;

   DRAWTEXT(DISP=2,ZSH,'中枢'),COLORRED;

  中枢高:PLOYLINE(DISP=2,REF(ZSD,BARSLAST(TJ8))),CROSSDOT,COLORLIRED;

  中枢低:PLOYLINE(DISP=2,REF(ZSG,BARSLAST(TJ8))),CROSSDOT,COLORLIGREEN;

  中枢最高:PLOYLINE(DISP=2,REF(ZSH,BARSLAST(TJ8))),POINTDOT,COLORRED;

  中枢最低:PLOYLINE(DISP=2,REF(ZSL,BARSLAST(TJ8))),POINTDOT,COLORGREEN;

  局部低点预选A:=BACKSET(LLV(L,5)<REF(LLV(L,4),1),4);

  局部低点预选B:=BACKSET(局部低点预选A=0 AND REF(局部低点预选A,1)=1,2);

  局部低点预选C:=IF(局部低点预选B=1 AND REF(局部低点预选B,1)=0,-1,0);

  局部高点预选A:=BACKSET(HHV(H,5)>REF(HHV(H,4),1),4);

  局部高点预选B:=BACKSET(局部高点预选A=0 AND REF(局部高点预选A,1)=1,2);

  局部高点预选C:=IF(局部高点预选B=1 AND REF(局部高点预选B,1)=0,1,0);

  缺口判断:=IF(L>REF(H,1),1,IF(H<REF(L,1),-1,0));

  距前高天:=BARSLAST(局部高点预选C=1);

  距前低天:=BARSLAST(局部低点预选C=-1);

  小值周期:=LOWRANGE(L);

  大值周期:=TOPRANGE(H);

  低保留AA:=IF(局部低点预选C=-1 AND REF(距前高天,1)>REF(距前低天,1) AND LLV(L,距前高天+1)<REF(LLV(L,距前高天+1),1),-1,0);

  低保留AB:=IF(局部低点预选C=-1 AND REF(距前高天,1)<=REF(距前低天,1) AND (距前高天>=4 OR LLV(缺口判断,距前高天)=-1 OR LLV(L,距前低天+2)<REF(LLV(L,距前低天+1),1)),-1,0);

  低保留S:=IF((低保留AA=-1 OR 低保留AB=-1) AND L<REF(H,距前高天+1),-1,0);

  预判:=IF((距前低天<4 AND HHV(缺口判断,距前低天)!=1) OR REF(低保留S,距前低天)=0,1,0);

  判断:=IF(局部高点预选C=1 AND REF(距前低天,1)<=REF(距前高天,1) AND 预判=1 AND 大值周期>REF(小值周期,距前低天+1) AND 大值周期>REF(小值周期,距前低天) AND 大值周期>REF(大值周期,距前高天),1,0);

  高保留A:=IF(局部高点预选C=1 AND REF(距前低天,1)>REF(距前高天,1) AND HHV(H,距前低天+1)>REF(HHV(H,距前低天+1),1),1,0);

  高保留B:=IF(局部高点预选C=1 AND REF(距前低天,1)<=REF(距前高天,1) AND REF(低保留S,距前低天)=-1 AND (距前低天>=4 OR HHV(缺口判断,距前低天)=1),1,0);

  高保留:=IF((高保留A=1 OR 高保留B=1 OR 判断=1) AND H>REF(L,距前低天+1),1,0);

  预判A:=IF((距前高天<4 AND HHV(缺口判断,距前高天)!=1) OR REF(高保留,距前高天)=0,1,0);

  判断A:=IF(局部低点预选C=-1 AND REF(距前高天,1)<=REF(距前低天,1) AND 预判A=1 AND 小值周期>REF(大值周期,距前高天+1) AND 小值周期>REF(大值周期,距前高天) AND 小值周期>REF(小值周期,距前低天),-1,0);

  低保留A:=IF(局部低点预选C=-1 AND REF(距前高天,1)>REF(距前低天,1) AND LLV(L,距前高天+1)<REF(LLV(L,距前高天+1),1),-1,0);

  低保留B:=IF(局部低点预选C=-1 AND REF(距前高天,1)<=REF(距前低天,1) AND (距前高天>=4 OR LLV(缺口判断,距前高天)=-1 OR 判断A=-1),-1,0);

  低保留:=IF((低保留A=-1 OR 低保留B=-1) AND L<REF(H,距前高天+1),-1,0);

  距前高天A:=BARSLAST(高保留=1);

  距前低天A:=BARSLAST(低保留=-1);

  预判X:=IF((距前低天A<4 AND HHV(缺口判断,距前低天A)!=1) OR REF(低保留,距前低天A)=0,1,0);

  判断X:=IF(局部高点预选C=1 AND REF(距前低天A,1)<=REF(距前高天A,1) AND 预判X=1 AND 大值周期>REF(小值周期,距前低天A+1) AND 大值周期>REF(小值周期,距前低天A) AND 大值周期>REF(大值周期,距前高天A),1,0);

  高保留XA:=IF(局部高点预选C=1 AND REF(距前低天A,1)>REF(距前高天A,1) AND HHV(H,距前低天A+1)>REF(HHV(H,距前低天A+1),1),1,0);

  高保留XB:=IF(局部高点预选C=1 AND REF(距前低天A,1)<=REF(距前高天A,1) AND REF(低保留,距前低天A)=-1 AND (距前低天A>=4 OR HHV(缺口判断,距前低天A)=1),1,0);

  高保留X:=IF((高保留XA=1 OR 高保留XB=1 OR 判断X=1) AND H>REF(L,距前低天A+1),1,0);

  预判XA:=IF((距前高天A<4 AND HHV(缺口判断,距前高天A)!=1) OR REF(高保留XA,距前高天A)=0,1,0);

  判断XA:=IF(局部低点预选C=-1 AND REF(距前高天A,1)<=REF(距前低天A,1) AND 预判XA=1 AND 小值周期>REF(大值周期,距前高天A+1) AND 小值周期>REF(大值周期,距前高天A) AND 小值周期>REF(小值周期,距前低天A),-1,0);

  低保留XA:=IF(局部低点预选C=-1 AND REF(距前高天A,1)>REF(距前低天A,1) AND LLV(L,距前高天A+1)<REF(LLV(L,距前高天A+1),1),-1,0);

  低保留XB:=IF(局部低点预选C=-1 AND REF(距前高天A,1)<=REF(距前低天A,1) AND (距前高天A>=4 OR LLV(缺口判断,距前高天A)=-1 OR 判断XA=-1),-1,0);

  低保留X:=IF((低保留XA=-1 OR 低保留XB=-1) AND L<REF(H,距前高天A+1),-1,0);

  距前高天YA:=BARSLAST(高保留X=1);

  距前低天YA:=BARSLAST(低保留X=-1);

  预判YX:=IF((距前低天YA<4 AND HHV(缺口判断,距前低天YA)!=1) OR REF(低保留X,距前低天YA)=0,1,0);

  判断YX:=IF(局部高点预选C=1 AND REF(距前低天YA,1)<=REF(距前高天YA,1) AND 预判YX=1 AND 大值周期>REF(小值周期,距前低天YA+1) AND 大值周期>REF(小值周期,距前低天YA) AND 大值周期>REF(大值周期,距前高天YA),1,0);

  高保留YXA:=IF(局部高点预选C=1 AND REF(距前低天YA,1)>REF(距前高天YA,1) AND HHV(H,距前低天YA+1)>REF(HHV(H,距前低天YA+1),1),1,0);

  高保留YXB:=IF(局部高点预选C=1 AND REF(距前低天YA,1)<=REF(距前高天YA,1) AND REF(低保留X,距前低天YA)=-1 AND (距前低天YA>=4 OR HHV(缺口判断,距前低天YA)=1),1,0);

  高保留YX:=IF((高保留YXA=1 OR 高保留YXB=1 OR 判断YX=1) AND H>REF(L,距前低天YA+1),1,0);

  预判YXA:=IF((距前高天YA<4 AND HHV(缺口判断,距前高天YA)!=1) OR REF(高保留YXA,距前高天YA)=0,1,0);

  判断YXA:=IF(局部低点预选C=-1 AND REF(距前高天YA,1)<=REF(距前低天YA,1) AND 预判YXA=1 AND 小值周期>REF(大值周期,距前高天YA+1) AND 小值周期>REF(大值周期,距前高天YA) AND 小值周期>REF(小值周期,距前低天YA),-1,0);

  低保留YXA:=IF(局部低点预选C=-1 AND REF(距前高天YA,1)>REF(距前低天YA,1) AND LLV(L,距前高天YA+1)<REF(LLV(L,距前高天YA+1),1),-1,0);

  低保留YXB:=IF(局部低点预选C=-1 AND REF(距前高天YA,1)<=REF(距前低天YA,1) AND (距前高天YA>=4 OR LLV(缺口判断,距前高天YA)=-1 OR 判断YXA=-1),-1,0);

  低保留YX:=IF((低保留YXA=-1 OR 低保留YXB=-1) AND L<REF(H,距前高天YA+1),-1,0);

   AAAD:=IF(高保留YX=1 AND 低保留YX=-1 AND H>REF(H,REF(距前高天YA,1)+2),1,IF(高保留YX=1 AND 低保留YX=-1 AND L<REF(L,REF(距前低天YA,1)+2),-1,0));

  极点保留:=IF(AAAD=0,高保留YX+低保留YX,AAAD);

  局部极点:IF(极点保留=-1,L,IF(极点保留=1,H,DRAWNULL)) CIRCLEDOT COLORYELLOW;

   DRAWLINE(极点保留=-1,局部极点,极点保留=1,局部极点,0)COLORLIRED;

   DRAWLINE(极点保留=1,局部极点,极点保留=-1,局部极点,0)COLORYELLOW;

   DD1:=BARSLAST(ABS(极点保留)!=1);

   DRAWTEXT(极点保留=1,局部极点,'*'),COLORGREEN;

   DRAWTEXT(极点保留=-1,局部极点,'*'),COLORRED;

  倍量:=VOL>=REF(V,1)*1.91 AND C>O;

  缩量:=REF(V,1)>=VOL*1.91 AND C<O;

   STICKLINE(倍量,OPEN,CLOSE,2,0),COLORRED;

   STICKLINE(缩量,OPEN,CLOSE,2,0),COLORGREEN;

   C2:=REF(C,1);

  涨停:=IF((C-C2)*100/C2>=(10-0.01*100/C2),1,0);

  

  本站关于“600125资金流向:通达信中枢缠绵主图指标源码”的内容基本完结,更多精彩敬请关注!

编辑:股海冲浪板
版权声明:来源:600125资金流向:通达信中枢缠绵主图指标源码http://www.yaimei.com/soft/8509.html 以下是通达信中枢缠绵主图指标源码(注:若无源码的请联系本站客服索取或下载附件自行导入软件),,本公式由花都股票网证券资深从业人员收集整理发布,欢迎广大股民朋友下载使用...