操盘手之家是国内最好的最全面的股票知识学习网站,提供股票基础知识,股票入门书籍和视频教程,技术指标教程等。
股票学习网 > 指标公式 > 大智慧公式 > 大智慧新一代主图叠加成交量(大智慧L2)

大智慧新一代主图叠加成交量(大智慧L2)   

来源:767学习网  阅读: 2021年07月02日 22:15:09

  大智慧新一代主图叠加成交量(大智慧L2),下面是本站编辑关于大智慧新一代主图叠加成交量(大智慧L2)的详情解说:

DRAWGBK(c>0),color000000;
{以下设置均线};
MA5:MA(C,5),colorFFFFFF,LAYER2;
MA13:MA(C,13),color00EEEE,LAYER2;
MA21:MA(C,21),colorEE00EE,LAYER4;
MA34:MA(C,34),color00EE00,LAYER4;
DRAWGBK(c>0),color000000;
{以下设置主图坐标};
WZ:=BARSLAST(DISPSTATUS=1);
PZ:=BACKSET(DISPSTATUS=2,WZ/2+50);
KZ:=BARSLAST(CROSS(PZ,0.5));
KJZ:=HHVALL(HIGH)-LLVALL(LOW);
平衡:=LLVALL(LOW)+KJZ/2;
支撑:=IF(KZ>=0,LLVALL(LOW)+KJZ*0.191,平衡);
中心值:=支撑*0.7;
中心值1:=支撑*0.8;
底线:支撑*0.675,pointdot,COLOR000000,LAYER7;
{以下设置主图成交量};
量比例:=(支撑*0.15)/HHVALL(V);
MV5:MA(量比例*V,5)+中心值,color00FFFF,LAYER2;
MV34:MA(量比例*V,34)+中心值,colorEE00EE,LAYER3;
STICKLINE(c>=O, 中心值, 中心值+量比例*V,5,1),COLOR5050FF,LAYER7;
STICKLINE(C<O, 中心值, 中心值+量比例*V,5,0),COLORFFFF00,LAYER7;
DRAWTEXT(BARSTATUS=2 and V>=REF(V,1),中心值*0.996,'↑'),COLORRED,LINETHICK1,ALIGN1;
DRAWTEXT(BARSTATUS=2 and V<REF(V,1),中心值*0.996,'↓'),COLOREEEE00,LINETHICK1,ALIGN1;
{以下设置有庄出现};
AA6:=CROSS(MA(C,5),MA(C,20)) AND CROSS(MA(C,5),MA(C,30)) AND CROSS(MA(C,5),MA(C,60));
BB6:=MA(C,60)>MA(C,10) AND CROSS(MA(C,10),MA(C,30)) AND MA(C,30)>MA(C,20) AND ABS(MA(C,60)-MA(C,20))/MA(C,20)<0.05;
CC6:=MA(C,30)>MA(C,5) AND CROSS(MA(C,5),MA(C,20)) AND MA(C,20)>MA(C,10);
DD6:=ABS((MA(C,5)-MA(C,10))+(MA(C,10)-MA(C,20))+(MA(C,20)-MA(C,30)))<0.02 AND MA(C,5)>REF(MA(C,5),1) AND MA(C,10)>REF(MA(C,10),1);
EE6:=MA(C,20)>MA(C,5) AND CROSS(MA(C,5),MA(C,10)) AND MA(C,10)>MA(C,60) AND ABS(MA(C,20)-MA(C,60))/MA(C,60)<0.05;
有庄出现:=AA6 OR BB6 OR CC6 OR DD6 OR EE6 ;
DRAWICON(FILTER(有庄出现=1,3) ,中心值,14),ALIGN1;
{以下设置个股信息}
DRAWTEXTABS(1,6,'■'+STKLABEL+' '+STKNAME+' '+',流通股: '+FINANCE2(37)/10000+' , '+BKNAME),COLORFF88FF,LAYER0;
年1:=YEAR;
月1:=MONTH;
日1:=DAY;
星期:=WEEKDAY;
DRAWTEXTREL(5,65,NUMTOSTR(年1)+'年 '+NUMTOSTR(月1)+'月'+NUMTOSTR(日1)+'日 星期'+NUMTOSTR(星期)),LINETHICK2,COLOR00ffFF;
{以下设置青龙取水}
nA1:=MIN(MA(C,5),MA(C,10))>MA(C,60) AND CROSS(MA(C,5),MA(C,10));
nA2:=MIN(MA(C,5),MA(C,10))/MA(C,60)<1.05;
nA3:=COUNT(V<MA(V,10),10)>6;
青龙取水:=nA1 AND nA2 AND nA3;
DRAWTEXT(FILTER(青龙取水=1,5),L*0.93,' '),LAYER2;
DRAWICON(FILTER(青龙取水=1,5),L*0.92,1),ALIGN1,LAYER7;
{以下设置B买点}
VAR32:=(CLOSE-LLV(LOW,20))/(HHV(HIGH,20)-LLV(LOW,20))*100;
VAR33:=SMA(SMA(VAR32,3,1),3,1)/28.57;
VAR34:=EMA(VAR33,5);
VAR35:=3*VAR33-2*VAR34;
绝买:=CROSS(VAR35,VAR33) AND VAR33<2.1 and c>o;
DRAWTEXT(绝买=1,L*0.975,'B'),ALIGN1,COLOR00BBBB,LINETHICK3,LAYER2;
{以下设置东郭立体K线};
STICKLINE(CLOSE>OPEN,OPEN,LOW,0.5,0 ),COLOR0000FF;
STICKLINE(CLOSE>OPEN,CLOSE,HIGH,0.5 ,0 ),COLOR0000FF;
STICKLINE(OPEN>=CLOSE,CLOSE,LOW,0.5 ,0 ),COLOR00FF00;
STICKLINE(OPEN>=CLOSE,OPEN,HIGH,0.5 ,0 ),COLOR00FF00;
STICKLINE(OPEN>=CLOSE ,CLOSE ,OPEN,7,0 ),COLORff7700;
STICKLINE(OPEN>=CLOSE ,CLOSE ,OPEN,6,0 ),COLORff9900;
STICKLINE(OPEN>=CLOSE ,CLOSE ,OPEN,5,0 ),COLORffbb00;
STICKLINE(OPEN>=CLOSE ,CLOSE ,OPEN,4,0 ),COLORffcc00;
STICKLINE(OPEN>=CLOSE ,CLOSE ,OPEN,3,0 ),COLORffdd00;
STICKLINE(OPEN>=CLOSE ,CLOSE ,OPEN,2,0 ),COLORffee00;
STICKLINE(OPEN>=CLOSE ,CLOSE ,OPEN,1,0 ),COLORffFF00;
STICKLINE(CLOSE>OPEN,CLOSE,OPEN,7,0) ,COLOR000055;
STICKLINE(CLOSE>OPEN,CLOSE,OPEN,6,0) ,COLOR000066;
STICKLINE(CLOSE>OPEN,CLOSE,OPEN,5,0) ,COLOR000077;
STICKLINE(CLOSE>OPEN,CLOSE,OPEN,4,0) ,COLOR000099;
STICKLINE(CLOSE>OPEN,CLOSE,OPEN,3,0) ,COLOR0000bb;
STICKLINE(CLOSE>OPEN,CLOSE,OPEN,2,0) ,COLOR0000dd;
STICKLINE(CLOSE>OPEN,CLOSE,OPEN,1,0) ,COLOR0000ff;
var9Q:=c= hhv(c,4)and (ref(c,1)>=ref(c,2) or ref(c,1)>=ref(c,3)) or ref(c,1)=hhv(c,4) and close>=ref(c,2) or ref(c,2)=hhv(c,4) and ref(c,3)=llv(c,4) and c>=ref(c,1) or ref(c,3)=hhv(c,4) and c>=ref(c,1) and c>=ref(c,2);
stickline(var9Q,c,(o+c)/2,7,0),color000055;
stickline(var9Q,c,(o+c)/2,6,0),color000066;
stickline(var9Q,c,(o+c)/2,5,0),color000077;
stickline(var9Q,c,(o+c)/2,4,0),color000099;
stickline(var9Q,c,(o+c)/2,3,0),color0000bb;
stickline(var9Q,c,(o+c)/2,2,0),color0000dd;
stickline(var9Q,c,(o+c)/2,1,0),color0000ff;
varaQ:=c=hhv(c,4) and ref(c,1)=llv(c,4);
stickline(varaQ,c,(o+c)/2,7,0),colorff11ff;
stickline(varaQ,c,(o+c)/2,6,0),colorff33ff;
stickline(varaQ,c,(o+c)/2,5,0),colorff55ff;
stickline(varaQ,c,(o+c)/2,4,0),colorff77ff;
stickline(varaQ,c,(o+c)/2,3,0),colorff99ff;
stickline(varaQ,c,(o+c)/2,2,0),colorffbbff;
stickline(varaQ,c,(o+c)/2,1,0),colorffddff;
varbQ:=c=llv(c,4) and (ref(c,1)<ref(c,2) or ref(c,1)<ref(c,3)) or ref(c,1)=llv(c,4) and c<ref(c,2) or ref(c,2)=llv(c,4) and ref(c,1)<>hhv(c,4) and c<ref(c,1) or ref(c,3)=llv(c,4) and c<ref(c,1) and c<ref(c,2);
stickline(varbQ,c,(o+c)/2,7,0),color333333;
stickline(varbQ,c,(o+c)/2,6,0),color555555;
stickline(varbQ,c,(o+c)/2,5,0),color777777;
stickline(varbQ,c,(o+c)/2,4,0),color999999;
stickline(varbQ,c,(o+c)/2,3,0),colorbbbbbb;
stickline(varbQ,c,(o+c)/2,2,0),colordddddd;
stickline(varbQ,c,(o+c)/2,1,0),colorffffff;
varcQ:=ref(c,1)=llv(c,4) and c>=ref(c,2) or ref(c,2)=llv(c,4) and ref(c,1)<=ref(c,3) and ref(c,2)<ref(c,4) and c>=ref(c,1);
stickline(varcQ,o,(o+c)/2,7,0),color003300;
stickline(varcQ,o,(o+c)/2,6,0),color005500;
stickline(varcQ,o,(o+c)/2,5,0),color007700;
stickline(varcQ,o,(o+c)/2,4,0),color009900;
stickline(varcQ,o,(o+c)/2,3,0),color00bb00;
stickline(varcQ,o,(o+c)/2,2,0),color00dd00;
stickline(varcQ,o,(o+c)/2,1,0),color00ff00;
vardQ:=ref(c,1)=hhv(c,4) and c<ref(c,2) or (ref(c,2)=hhv(c,4) and ref(c,1)>ref(c,3) or ref(c,3)=hhv(c,4) and ref(c,1)>ref(c,2)) and ref(c,2)>=ref(c,4) and c<ref(c,1);
stickline(vardQ,o,(o+c)/2,7,0),colorff1100;
stickline(vardQ,o,(o+c)/2,6,0),colorff3300;
stickline(vardQ,o,(o+c)/2,5,0),colorff5500;
stickline(vardQ,o,(o+c)/2,4,0),colorff7700;
stickline(vardQ,o,(o+c)/2,3,0),colorff9900;
stickline(vardQ,o,(o+c)/2,2,0),colorffbb00;
stickline(vardQ,o,(o+c)/2,1,0),colorffdd00;
STICKLINE(VARBQ AND C>O AND H>=C AND L<=O ,H,L,1.5,0) ,COLORYELLOW,LAYER2;

  以上就是关于“大智慧新一代主图叠加成交量(大智慧L2)”的介绍。

  以上便是大智慧新一代主图叠加成交量(大智慧L2)http://www.yaimei.com/dazhihui/20540.html的相关信息了,希望能帮助到大家,更多金融理财相关信息,敬请关注767学习网!

编辑:韩立